MS SQL ‘de Veritabanı için Diyagram Oluşturamama Sorunu

MS SQL kullanarak veritabanımız ile çalışırken sıklıkla diyagram’larla sorunsuz bir şekilde çalışabiliyoruz. Diyagram oluşturma esnasında alabileceğiniz diyagram oluşturamama sorunu söz konusu olabilir ki, aslında bunun sebeplerinden biri diyagramlar ile çalışmak için db_owner olarak ilgili veritabanına bağlantı kurduğunuz kullanıcının tanımlanmış olması gerekliliğidir.

Eğer bu sorun ile karşılatıysanız, aşağıdaki adımları takip ederek gerekli tanımı yapabilir ve diyagram oluşturabilir ve diyagram ile çalışabilirsiniz. (Devamını okuyun)

kmb-udemy-reklam

“MS SQL ‘de Veritabanı için Diyagram Oluşturamama Sorunu” yazısını okumaya devam et

Reklamlar

Visual Studio 2010 Toolbox Yüklenme Problemi

Eğer VS 2010 toolbox ‘ın bazı sebeplerden dolayı(3.parti component yüklenmesi, resetlenmesi vs..) yavaşlayabilmesi mümkün. Bu durumda açılışta yaklaşık 55 dk (ki bu bilgisayarın performansına göre değişir) gibi bir bekleme süresi ile karşılaşabilirsiniz. Bunu engellemek için; toolbox’ın ilk yüklendiği durumuna grei getirilmesini sağlamak adına “resetlemek” pek işe yaramamaktadır. Biraz manuel bir yolla bunu işlemi şu şekilde yaparak VS 2010 açılışınızı eski haline getirebilirsiniz.. Fakat component’leri tekrar toolbox’a bağlamanız gerekecektir..

Daniel Carey’in çözümünü aynen paylaşıyorum.. 10.0” eki alanlar VS 2010 için; “9.0” eki alanlar VS 2008 içindir..

Posted by Daniel Carey on 15.04.2010 at 10:40

Searched through registry looking for “2c298b35-07da-45f1-96a3-be55d91c8d7a”. Backed up the registry key and deleted it.
Found the entries in the following locations:

1. [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0_Config\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}]
2. [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0Exp\Configuration\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}]
3. [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}]
4. [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}]
5. [HKEY_USERS\.DEFAULT\Software\Microsoft\VisualStudio\10.0_Config\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}]
6. [HKEY_USERS\S-1-5-21-2705550674-1607040020-2235880358-1109\Software\Microsoft\VisualStudio\10.0_Config\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}]

Kaynak (workaround sekmesinde bulabilirsiniz..)

ASP.NET – Internet Explorer ASP.NET Web Sayfası Görüntülenemiyor Sorunu.

“Internet Explorer cannot display the webpage” from IE7 – ASP.NET Development Server Error?

Geçtiğimiz 2-3 gündür aklımdan bir türlü çıkaramadığım ve nette girilmedik sayfa bırakmadığım. Aklıma geldikçe yüzümün asıldığı ve uykularımın kaçtığı bir sorunu çözmenin, daha doğrusu çözümünü bulmanın sevincini yaşıyorum.

Başlıkta da belirttiğim gibi sorun; daha önceden geliştirdiğim asp.net web application ve asp.net web site uygulamalarının Visual Studio 2008, 2005 IDE’sinde F5 ile RUN ettiğim halde intenet explorer tarafından görünmemesiydi. Halbuki bilgisayarımda VS ya da IIS ile ilgili bir değişikde yapmamıştım. Sadece son zamanlarda öğrendiğim ve çok hoşuma giden ADO.NET Data Services uygulamaları geliştirmek için VS 2008 SP1 ‘i yüklemiştim.

Yüklediğim Ado.Net Data Services template’i ile ilgili bir örnek uygulama geliştirdiğimde ilk hatayı aldım ve doğal olarak Ado.Net Data Services uygulama ayarlarının IIS altına düzgün yüklenmediğinden şüphelendim. VS 2008 ‘de çalışmayan uygulama “kısmen” olarak IIS ‘e publish ettiğimde çalışıyordu. Eeee neden VS ‘da F5 ile çalıştıramıyordum? Bu öyle canımı sıktı ki hiç aspx uygulamalarınında çalışmadığını farketmedim. Asık olan yüzüm iyice asılmıştı. Ben ne değiştirdim ki bu hale geldi demeye başladım.

IIS ‘in tekrar kaldırılıp kurulmasından, ServiceModelReg.exe uygulamasının çalıştırılmasına varana kadar ve hatta VS 2008 ‘in yüklü olduğu halde tekrar kurulmasını deneyecek kadar ileri giden işlemler sonunda sorunun ne IIS’de ne de VS ‘da olduğunu anladığımda tam bir yıkım oldu :)) Sorunun kaynağı 2-3 gün önce kurduğum NOD32 antivirüs programıymış. Belki diğer anti-virüs uygulamalarıda bu olaya sebep olabilir.

Meğerse NOD32 Web Access Protection koruması altında VS 2008’in web uygulamasının localhost’da port açarak IE’ı kullanmasını engelliyormuş. NOD32 gelişmiş ayarlarından gerekli ayarları yapınca bunun düzeldiğini gördüğümde nasıl sevindiğimi anlatamam. Neredeyse makinaya format atmayı düşünüyordum. Bu da nerden baksanız 2-3 gün kendime gelememem demekti. :))


Sorunun çözümü;

bu adresten daha detaylı inceleyebilirsiniz.. Kısaca anlatmak gerekirse de;




resimde gördüğünüz gibi NOD32 anti-virüs uygulamasının gelişmiş ayarlar(Advanced setup) bölümünde “web access protection” alanı altında “web browsers” ‘a tıklayınız. Orada VS 2008 ile ilgili satırdaki kutucuğa “x” işaretini koyunuz. Şimdi VS 2008 ‘de projenizi F5 ile çalıştırınız..


İyi Çalışmalar 🙂